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 SAOImage DS9 Users Manual

The DS9 Users Manual leads the user step-by-step through many features of ds9, such as data binning and
contours. For an in-depth description of all of ds9’s capabilities, refer to the Reference Manual 

Introduction to the ds9 Interface 

Binning and Filtering FITS Event Files 

Contours 

Create a True Color Image in an RGB frame 

Scripting ds9 

If there are topics that you would like to see covered in the Users Manual, please email: saord @
cfa.harvard.edu. 
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Introduction to the ds9 Interface
Return to the DS9 Users Manual

Synopsis
This thread provides an overview of the key components of the ds9 graphical user interface (GUI). 

Last Update: 6 Jul 2009 - Original version 

Contents
The ds9 Interface

1.  Menu bar 
2.  Information panel 
3.  Panner 
4.  Magnifier 
5.  Buttons 
6.  Display frame 
7.  Colorbar

Setting and Saving View Preferences 
History  
Images

Figure 1: The ds9 GUI 
Figure 2: The ds9 GUI, vertical layout 
Figure 3: Menu bar 
Figure 4: Tearing off a Menu 
Figure 5: Information panel 
Figure 6: Panner 
Figure 7: Magnifier 
Figure 8: Buttons 
Figure 9: Tiled frame display 
Figure 10: Colorbar 
Figure 11: Preferences dialog box

The ds9 Interface
This thread uses Chandra data from an observation of the Trapezium Cluster (ObsID 1522). The default
ds9 GUI is shown in Figure 1. The main components are numbered: 
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1.  Menu bar 
2.  Information panel 
3.  Panner 
4.  Magnifier 
5.  Buttons 
6.  Display frame 
7.  Colorbar 

Figure 1: The ds9 GUI
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The default setup is a "horizontal layout", with the information panel, panner, magnifier, and buttons
displayed horizontally across the window. This may be changed to "vertical layout" in the View menu 
(Figure 2). 
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Figure 2: The ds9 GUI, vertical layout

Note that the colorbar remained horizontal at the bottom of the display frame. This may be changed with
the "vertical colorbar" option in the "View" menu. 
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1. Menu bar

The menu bar provides access to all of ds9’s capabilities. For a complete description of each menu, refer
to the Menu bar section of the Reference Manual. 

Figure 3: Menu bar

All ds9 menus can be "torn off" to be a separate window from the main GUI. To tear off a menu, select the
dashed line, which is the first item of each menu (shown in Figure 4). The menu will become its own
window. 

Figure 4: Tearing off a Menu
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2. Information panel

The information panel displays information about the data file and the values at the cursor position. In 
Figure 5, the object name has been loaded from the header of the data file. The image value and position
(in WCS, physical, and image coordinates) are updated in real time as the cursor is moved. 

The fields of the information panel can be customized from the "View" menu. Any of the default entries
can be removed, and additional fields can be added (e.g. detector coordinates, min/max data values). 

Figure 5: Information panel

3. Panner

The panner allows the user to view areas of the frame which are outside of the current field of view.
Although the display frame is filled by the data, the panner indicates that more of the image is available.
Clicking and dragging the viewing bounding box in the panner - shown in blue in Figure 6 - will display a
different portion of the image. 

The panner also contains axes to indicate the directions of North and East and the directions of the
physical (x,y) data axes. 

Figure 6: Panner
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4. Magnifier

The magnifier displays a magnified view of the current cursor location. The magnifier cursor - the small
square in the center of Figure 7 - outlines the size and orientation of one pixel, taking into account the
current frame zoom and orientation. 

Figure 7: Magnifier

5. Buttons

The button bar duplicates many of the options available from the menu bar. The buttons provide quick
access to change the most frequently-used ds9 actions (e.g. changing the scale and color bar, blinking and
tiling frames). 

When a category is chosen from the top row, the options within that category are displayed in the bottom
row of buttons. In Figure 8, the color category is chosen and the bottom row shows the ten most-used
colormap options (additional colormaps are available from the "Color" menu). 

Figure 8: Buttons

6. Display frame

The display frame is the area of ds9 where the FITS image is shown. In Figure 1, a single frame is shown. 

Multiple frames can be opened in ds9 at the same time. In Figure 9, nine frames have been opened and set
to "tile" display from the "frame" button. The current frame is indicated by a blue outline around it
(second row, center frame). How the frames are tiled is set in the "Frame â Frame Parameters â Tile"
menu; the default is to tile the frames in a grid. 
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Figure 9: Tiled frame display
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If the display is set back to "single", then the current frame fills the display area. The other frames can be
accessed via the "previous" and "next" options in the buttons bar (or from the "Frame" menu). 

The "blink" option may also be used with multiple frames. When blink is turned on, ds9 cycles through all
the available frames. The blink interval is set in the "Frame â Frame Parameters â Blink Interval" menu. 

7. Colorbar

The colorbar displays the colormap, bias, and contrast settings. The colormap correlates the colors used in
the image with the pixel values in the data. 

To change the colormap, use the "Color" menu or button. The contrast and bias can be adjusted by
right-clicking and dragging on the ds9 display. The "Color â Colormap Parameters" dialog box can also be
used to change contrast and bias. 

Figure 10: Colorbar

Setting and Saving View Preferences
All of the view options described in this thread can be set and saved as a preference. Open the
"Preferences" dialog box from the "Edit" menu and select the "View" tab, shown in Figure 11. 

Figure 11: Preferences dialog box
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The "Default" menus are used to set the defaults of the "View" menu and buttons. For instance, uncheck
the "Panner" item under "Menu" and the panner won’t be displayed when ds9 is launched. (Note that some
options require ds9 to be restarted before they take effect.) 

After setting the desired preferences, select "Save". User preferences are stored in .ds9.prf . At startup,
ds9 looks for the preferences file in the following directory order: ./ , $HOME, /usr/local/lib , 
/opt/local/lib . 

History

06Â JulÂ 2009 Original version 

Return to the DS9 Users Manual
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Binning and Filtering FITS Event Files
Return to the DS9 Users Manual

Synopsis
When an x-ray event file is loaded, ds9 makes a virtual image for display by binning on one or more axes.
This threads describes how to adjust the binning and buffer sizes. Interactive data filtering is described, as
well as binning in three dimensions. 

Note that the terms "binning" and "blocking" are used interchangeably in this thread. They both refer to
combining pixels in an image. 

Last Update: 26 Jun 2009 - Original version 

Contents
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Changing the binning factor 
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Filtering Data 
History  
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Figure 11: Filtering data

13



Getting Started
This thread begins with Chandra data from an observation of the Antennae Galaxies (NGC 4038/NGC
4039, ObsID 315). Open the file in ds9: 

unix% ds9 acisf00315N002_evt2.fits &

A small section of the data is visible when the file is loaded, as shown in Figure 1. The target of the
observation is partially visible in the display frame. 

Figure 1: Data loaded with default buffer and bin size
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By default, the buffer size is set to 1024x1024 and the binning factor is set to 1. These values will be
adjusted in the following sections to illustrate how to make more of the data visible. 

The "Bin" menu, shown in Figure 2, will be used to change the setting in the following examples. From
top to bottom, this menu contains the bin function setting, blocking factor, buffer size options, and access
to the binning parameters dialog box. 

Figure 2: The Bin menu
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Buffer Size
The buffer size determines the size of the image generated by ds9. By default, a full-resolution 1024x1024
image of the data is created. If your input data file has larger dimensions, it is clipped to 1024x1024 in
ds9. The buffer settings range from 128x128 to 8192x1892. 

Setting the buffer to the smallest size, 128x128, illustrates how it works. The data was centered on the
sources in ds9 before the buffer size was changed, creating Figure 3. 

Figure 3: Buffer size set to 128x128
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Setting the buffer to a large size, e.g. 4096x4096, produces Figure 4. The display frame is filled by the
data, and the panner in the upper right indicates that more of the image is available. Clicking and dragging
the viewing bounding box in the panner will display a different portion of the image. 

Figure 4: Buffer size set to 4096x4096
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Binning Basics

Changing the binning factor

While increasing the buffer size loads more of the file into ds9, binning the data makes more of it visible
in the frame. Binning combines the specified number of pixels into one new pixel; the new pixel has a
value equal to the sum of the original pixels. (Note that if the bin method is changed to "average", the
pixel values are averaged instead of summed.) 

The binning can changed from the "Bin" menu or from the "Bin" item in the button bar. It’s also possible
to step through different binning values with the -/+ buttons or the "Block In"/"Block Out" menu items. 

In Figure 5, the buffer size is set to 1024x1024, but the block factor has been set to 4. A larger section of
the data is visible in the frame. 

Figure 5: Data binned by a factor of 4
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Binning different columns

ds9 has the ability to display any of the other columns stored in the event file, although it is generally only
meaningful to use the spatial vector columns. Begin by opening the "Bin â Binning Parameters" dialog
box, shown in Figure 6. 

The "Bin Columns" menus are used to select the columns to be binned. To create an image in detector
coordinates, set the first to "detx" and the second to "dety"; the block is set to "2" for both. The "or center
of data" box is checked so that the center of the data is recalculated for the new columns. 

Figure 6: The Binning Parameter dialog

Click "Apply" and the ds9 frame is updated, as shown in Figure 7. 

Figure 7: Image binned in detector coordinates
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Alternatively, one can display an event file in specific coordinates when starting ds9 from the command
line: 

unix% ds9 "acisf00315N002_evt2.fits[bin=detx,dety]" &

Data Cubes: Binning in three dimensions
It is possible to add a third column to the binning, creating a 3-dimensional image also known as a "data
cube". In this example, an (x,y,time) data cube is created of a Chandra observation of Jupiter (ObsID
1463). A cube may be created from any three columns that make sense in the analysis. For instance, you
may want to create a PHA or energy axis to see how the spectral characteristics of a source change over
time. 

The data file is loaded into a new frame in ds9 and the "Bin â Binning Parameters" dialog box is opened
again. The "time" column of the file is selected from the "Bin 3rd Column" menu. The limits of the data in
that column are filled in automatically. The "depth" field determines how many intervals the column is
divided into; a depth of 25 is used. The completed parameter box is shown in Figure 8. 

Figure 8: Binning Parameter dialog for a data cube

After clicking "Apply", two things happen: the "Data Cube" dialog box (Figure 9) is launched and the
frame is updated to show only the (x,y) image of the first time slice (Figure 10). (If the data cube dialog
box doesn’t launch, open it from the "Frame" menu.) 
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Figure 9: Data Cube dialog box

When "Play" is chosen, ds9 cycles through the bins of the time axis, essentially creating a movie of the
(x,y) position of the object over time. The speed of the frame changes is controlled from the "Interval"
menu of the dialog box. Any of the 25 intervals may be selected with the slider bar. 

Figure 10: Viewing a data cube
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The data cube can be saved as an MPEG movie from the "File â Save Image..." menu. Select "MPEG-1
(Movie)" and click "OK"; after setting the filename, choose an MPEG Quality Factor. The Jupiter data
was saved at a quality factor of 15: jupiter.mpg. 

Filtering Data
The "Bin Filter" field in the "Binning Parameters" dialog box is used to apply filters to the data. A filter
can be applied to any of the columns present in the input file. A colon is used to indicate a range of values.
Filters can also use < (less than) or > (greater than). 

For instance, to include only the hard-band photons (2500-8000 eV): 

energy=2500:8000

Clicking "Apply" updates the ds9 display and keeps the dialog open for adjusting the filters. 

Multiple filters may be specified, separated by commas: 

energy=2500:8000, ccd_id=7

The resulting image is shown in Figure 11. 

Figure 11: Filtering data
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The filtered dataset can be saved as a FITS file for use in data analysis from the "File â Save Frame as
Fits..." menu. 

History

26Â JunÂ 2009 Original version 

Return to the DS9 Users Manual
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Contours
Return to the DS9 Users Manual

Synopsis
Contours are curves along which the pixels have a constant value. ds9 can create and display contours as
an overlay on a data image. The contours can be copied between frames in the current session or saved to
file for future use with ds9. 

Last Update: 24 Jun 2009 - Original version 

Contents
Creating Contours on a Dataset 
Copying the Contours to Another Frame 
Saving the Contours 
Converting to Polygons and Saving 
History  
Images

Figure 1: Contour Parameters dialog box 
Figure 2: X-ray data with contours 
Figure 3: SAO-DSS Server dialog box 
Figure 4: X-ray and optical data with contours

Creating Contours on a Dataset
This thread uses Chandra data from an observation of the galaxy cluster Abell 2142 (ObsID 5005). 

After loading the data into ds9 and setting the desired scale, click on the "Contours" item in the "Analysis"
menu to turn on contour display. Open the "Contour Parameters" window from "Analysis â Contours
Parameters". There are two sliding scales which are used to set the number and smoothness of the contours
and fields for setting the range of values to use. 

Figure 1: Contour Parameters dialog box
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Typically, you will want to generate between 1 and 10 contours; larger numbers will take longer to
generate and display. A smoothness level of 1 will evaluate the contour at each image pixel, while a level
of 2 will evaluate the contour at every other pixel, and so on. A larger smoothing will generate contours
more quickly, but less detail will be available. 

By default, the range of the data scale is filled in as the limits. Under the "Method" menu, there are two
choices: 

1.  block (the default) - blocks down the image by the smoothness factor before contours are calculated.
The larger the smoothness, the faster the result. 

2.  smooth - smooths the image before calculating contours. The larger the smoothness, the slower the
result. 

In this example, the number of levels is set to 6 and the smoothing is set to 5. The contours will be
generated over the limit 1 to 100. The default method (block) is used. 

After clicking the "Generate" button, the list of contours is calculated and displayed in the "Levels"
portion of the window. Click "Apply" and the ds9 display is updated with the new contour levels, as
shown in Figure 2. 

Figure 2: X-ray data with contours
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The contour parameters can be adjusted until the desired result is achieved. Be sure to click "Generate"
whenever an adjustment is made so that the levels are recalculated. 

Copying the Contours to Another Frame
In this section, we take the X-ray contours just generated and display them on an optional image from the
Digital Sky Survey (DSS). 

From the "Analysis â Image Servers" menu, select one of the DSS server options (e.g. "SAO-DSS"). The
server dialog box allows you to retrieve an optical image of the field of your observation and load it into a
new frame. The default retrieval image size and (RA,Dec) is equal to the size and center of the field
currently displayed. Here the width and height have been set to 40, but the (RA,Dec) determined by ds9
are used. 

Figure 3: SAO-DSS Server dialog box

Click on "Retrieve" and the data is loaded into a new ds9 frame. 

To copy the x-ray contours: 

1.  Select the frame with the X-ray data in it. 

2.  Use "Frame â Match Frames â WCS" to align the two images. 

3.  To copy the contours, open the "Contour Parameters" dialog again and select "Copy Contours" from
the "File" menu. Leave the window open, as it is needed in a future step. 

4.  Select the frame with the optical data in it. 

5.  Using the "File" menu of the "Contour Parameters" dialog, select "Paste Contours". 
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6.  Adjust the parameters (if desired) in the small dialog box that is displayed, then click "OK". 

The optical image now has the x-ray contours overlaid. Since the WCS is the same, correlation between
x-ray and optical features may be seen. 

Figure 4: X-ray and optical data with contours
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To delete contours which have been pasted into a frame, select "Clear" from the "File" menu of the
"Contour Parameters" dialog. 

Saving the Contours
To save the contours to a text file, choose "Save Contours" from the "File" menu of the "Contour
Parameters" dialog. The contours are saved in a text file which can be loaded back into ds9 with the "Load
Contours" menu item. 

The contours generated in this thread have been saved as ds9.con. 

Converting to Polygons and Saving
The contours can be converted to ds9 polygon regions for use in filtering data. Converting to polygons
also allows you to select and/or delete specific contours. 

Note that the contours cannot be saved in ds9 format after converting. If you wish to save the
contours, do so before continuing. 

To convert the contours, select "Convert to Polygons" from the "File" menu of the "Contour Parameters"
dialog. The contours are now defined as ds9 polygons, e.g. 

polygon(3535.2112,4184.5,3540.5,4179.1154,3548.5,4176.8219,3555.9012,4184.5,3548.5,4191.9558,3540.5,4190.3926)

The polygon-shaped contours can be saved as a ds9 region file from the "Region Save â Regions" menu.
The region file for these contours has been saved as a2142.reg. 

History

24Â JunÂ 2009 Original version 

Return to the DS9 Users Manual
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Create a True Color Image in an RGB frame
Return to the DS9 Users Manual

Synopsis
Most astronomical images map color to intensity level, e.g. lighter tones may correspond to a brighter
intensity level in a greyscale image. An alternative way of presenting data is via an image that correllates
color and energy. 

ds9 has the capability to create an RGB image and interactively adjust many of its parameters to achieve
optimal display results. 

Last Update: 4 Jun 2009 - Original version 

Contents
Creating an RGB Frame
A.  From the command line 
B.  From the ds9 GUI

Apply Energy Filters 
Smoothing the Data (optional) 
Adjusting the Scale Parameters 
Adding a Coordinate Grid 
Saving the Output 
History  
Images

Figure 1: RGB window 
Figure 2: Lock menu in the RGB window 
Figure 3: RGB frame with three files loaded 
Figure 4: Energy-filtered RGB data 
Figure 5: Data smoothed with a Gaussian of radius three 
Figure 6: The adjusted pixel distribution for scaling 
Figure 7: Coordinate Grid parameters dialog box 
Figure 8: Final three-color image with coordinate grid overlaid

Creating an RGB Frame
To use the three-color capabilities of ds9, the data must be loaded into a special RGB frame. This frame
will contain all three files, stacked together in separate layers. 
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This thread uses Chandra data from an observation of Cas A (ObsID 198); the level=2 event file is named
"casa.fits". The same file is loaded into each layer of the RGB frame; different energy filters will be
applied to the layers in a later step. 

There are two options for creating the RGB frame: 

A. From the command line

The command-line syntax can be used to create the RGB frame and load the three files into the red, green,
and blue layers: 

unix% ds9 -rgb -red casa.fits \
               -green casa.fits \
               -blue casa.fits &

ds9 will open with the three files in one frame. The RGB window (Figure 1) should open as well. If it
doesn’t, open it from the "Frame â RGB..." menu. 

B. From the ds9 GUI

To load the files from the ds9 GUI: 

1.  Launch ds9 

2.  Choose "New Frame RGB" from the "Frame" menu. 

When the new frame is created, the RGB window (Figure 1) should open as well. If it doesn’t, open it
from the "Frame â RGB..." menu. 

3.  Make sure the "Red" band is selected in the "Current" column of the RGB window, then choose "File
â Open..." in the main ds9 window and select the red file. 

4.  Change the current band to "Green" in the RGB window and open the green file. 

5.  Change the current band to "Blue" in the RGB window and open the blue file. 

Figure 1: RGB window
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Each frame of the RGB image may have different binning, scaling, smoothing, and colorbars applied to it.
You can "lock" the frames together, so that the setting is applied to all three frames at once. This is done
with the Lock menu in the RGB window (Figure 2); all four options are checked in this thread. 

Figure 2: Lock menu in the RGB window

Use the binning and zoom options in ds9 to adjust the image so that the full region of interest is visible. 
Figure 3 uses binning=2 and zoom=1. The "Scale" is set to "log: minmax" 

Figure 3: RGB frame with three files loaded
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Apply Energy Filters
The following energy bands are used for the RGB layers: 

red (soft band): 200-1500 eV 
green (medium band): 1500-2500 eV 
blue (hard band): 2500-8000 eV 
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The values are just guidelines and may need to be adjusted for your analysis. 

To filter the data, first select the Red frame from the RGB window. Open the Bin â Binning 
Parameters  dialog box and type "energy=200:1500 " in the Bin Filter field. Choose "Apply" and
the ds9 display will be updated to reflect the energy filter. 

Without closing the Binning Parameters box, select the Green frame. Type "energy=1500:2500 " in
the Bin Filter field and choose "Apply" again. Repeat these two steps for the Blue layer, using the filter 
"energy=2500:8000 ". 

The colors in the image, as seen in Figure 4, are correlated to the energy of the data. 

Figure 4: Energy-filtered RGB data
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Smoothing the Data (optional)
Smoothing can help bring out finer features in the data by removing statistical noise. It is an optional step;
experiment with smoothing to see if it improves the appearance of your data. 

The smoothing capability in ds9 lets you interactively smooth the data. Note that for quantitative data
analysis, smoothing should be done with the appropriate data analysis software; ds9 does a nice job for
publication purposes. 
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Choose "Smooth" from the "Analysis" menu and the ds9 display is updated with the results of smoothing.
The "Smooth" option can be toggled on and off during your ds9 session. 

Open the "Smoothing Parameters..." dialog box from the same menu to adjust the function and kernel
radius of the smoothing. This data were smoothed with a Gaussian function with radius of two. The results
are shown in Figure 5. 

Figure 5: Data smoothed with a Gaussian of radius three
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Adjusting the Scale Parameters
This data is being displayed with a "log: minmax" scale. That means that ds9 stretches the scale to
encompass the range of pixel values in the file. Adjusting the minimum and maximum scale values sets a
threshold for the background data and brings out features. 

To change the minimum and maximum values, open the "Scale â Scale Parameters" dialog box. The pixel
distribution shown is for the band selected as "Current" in the RGB window; when the a different band is
selected, the histogram of pixel values is updated to match. 

To adjust the values, use the cursor to grab the red (minimum) or green (maximum) vertical lines on the
plot and drag them to the desired location. You can type a value in to the "Low" or "High" field and hit
"Apply" to set the limits. 

A basic guideline for setting the low value is to minimize the contribution of the background. That is,
adjust the minimum of each band until the background of the image is flat (i.e. solid black). For the
maximum value, bringing it in to the last data point in the pixel distribution is usually sufficient. 

For ObsID 198 with the smoothing applied, the following limits were chosen (listed as "low:high" pairs): 

Red - 0.4 : 20 
Green - 0.3 : 35 
Blue - 0.1 : 10 

Figure 6 shows the image with the new pixel value limits set. 

Figure 6: The adjusted pixel distribution for scaling
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Adding a Coordinate Grid
To add a coordinate grid to the image, choose the "Coordinate Grid" option from the "Analysis" menu.
Then choose "Coordinate Grid Parameters" from the same menu to open the preferences dialog (Figure 7). 
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Figure 7: Coordinate Grid parameters dialog box

From the preferences box, you can change the color, font, line style (solid or dash), and line thickness for
all elements of the grid. The font style, size, and color can be edited, and you can add titles. It is also
possible to turn off the display of individual items via the "View" menu. 

In Figure 8, we have turned off the grid lines and border. The axes have been changed to "Exterior Axes"
(from the "Type" menu). 

Figure 8: Final three-color image with coordinate grid overlaid
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Saving the Output
Once you are happy with your true color image, there are a number of output options in ds9. 

Image formats: from the "File â Save Image As..." menu, you can choose JPG, PNG, or TIFF file
formats. 
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Postscript: to create a postscript file, go to "File â Print..." and select "Print To: File". 

Currently it is not possible to save the state of the ds9 imager, meaning that you cannot save the composite
RGB frame and reopen later for further analysis. 

History

04Â JunÂ 2009 Original version 

Return to the DS9 Users Manual
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Scripting ds9
Return to the DS9 Users Manual

Synopsis
Scripting with ds9 can be done in several ways: by invoking the GUI with a number of command-line
options or via the XPA messaging system. A third option, Simple Application Messaging Protocol
(SAMP), is introduced but not included in the examples. 

To illustrate how to script ds9, we repeat the contours example with both methods,. The examples use
Chandra data from an observation of the galaxy cluster Abell 2142 (ObsID 5005). 

Last Update: 21 Sep 2009 - Original version 

Contents
Command-line Scripting 
XPA Scripting 
SAMP: Simple Application Messaging Protocol 
History  
Images

Figure 1: Command line: x-ray data with contours 
Figure 2: Command line: x-ray and optical data with contours 
Figure 3: XPA: x-ray data with contours 
Figure 4: XPA: x-ray and optical data with contours

Command-line Scripting
The ds9 Reference Manual has an extensive list of the available command line options. The most
important thing to note is that the commands are executed one at a time in the order they are listed. 

To create contours on a data image: 

unix% ds9 acisf05005N002_evt2.fits -bin about 3800 3800 -bin factor 2 \
    -scale log -cmap b \ 
    -contour yes -contour limits 1 100 \
    -contour smooth 5 -contour nlevels 6 -contour save ds9.con &

This command line produces Figure 1. 
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Figure 1: Command line: x-ray data with contours

The options direct ds9 to: 

1.  -bin about 3800 3800  : center the image display at (x,y)=(3800,3800) 
2.  -bin factor 2  : bin the data by a factor of 2 
3.  -scale log  : set the display to log scale 
4.  -cmap b  : use the "b" colormap 
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5.  -contour yes  : display contours 
6.  -contour limits 1 100  : set the minimum and maximum contour limits 
7.  -contour smooth 5  : set contour smoothness to "5" 
8.  -contour nlevels 6  : create six contour levels 
9.  -contour save ds9.com  : save the contours to the file "ds9.con" 

If you wish to add options to the command line after it has been processed, the whole command must be
run again from the beginning. It is, however, possible to interact with the ds9 GUI that has been created.
For instance, instead of including the "-bin about 3800 3800 " modifier, the image could be
recentered in ds9 interactively. 

The following command line builds on the previous example by retrieving a DSS image and copying the
contours to the new frame: 

unix% ds9 acisf05005N002_evt2.fits -bin about 3800 3800 -bin factor 2 \
    -scale log -cmap b \ 
    -contour yes -contour limits 1 100 \
    -contour smooth 5 -contour nlevels 6 -contour copy \
    -dsssao A2142 -cmap grey -contour paste \
    -frame first -match frames wcs &

The resulting image is shown in Figure 2. 

Figure 2: Command line: x-ray and optical data with contours
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The options which have been added from the previous command line are: 

1.  -contour copy  : copy the x-ray contours 
2.  -dsssao A2142  : retrieve a DSS image of A2142 from the DSS-SAO server (there are also a

"dsseso" and "dssstsci" options) 
3.  -cmap grey  : use the "grey" colormap in the DSS frame 
4.  -contour paste  : paste the x-ray contours onto the optical data 
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5.  -frame first  : select the first ds9 frame 
6.  -match frames wcs  : match the WCS of the DSS frame to the current (x-ray) frame 

At this point, we can end the ds9 session or modify the display interactively via the ds9 GUI. 

XPA Scripting
X Public Access (XPA) is a messaging system which provides communication between Unix programs
through a set of access points. The two most common actions are retrieving information (xpaget ) and
issuing commands (xpaset ). For more information, see the XPA Messaging System page and the XPA
Access Points section of the ds9 manual. 

XPA commands may be issued one at a time from the terminal or collected in a script to run in batch
mode. Unlike the command line syntax, there is no predetermined stopping point - commands may be sent
to ds9 as long as the GUI is open. 

First, open ds9 with the data file: 

unix% ds9 acisf05005N002_evt2.fits &

The xpans name server is used to manage the names and ports of XPA access points. Use "xpaget 
xpans " to see the list of available access points: 

unix% xpaget xpans
DS9 ds9 gs /tmp/.xpa/DS9_ds9.22972 username

Now that ds9 is running and linked to an XPA server, we can use xpaset to modify the display and add
contours. (Refer to the XPA documentation for details on xpaset  syntax.) 

unix% xpaset -p ds9 bin about 3800 3800 
unix% xpaset -p ds9 bin factor 2 
unix% xpaset -p ds9 scale log 
unix% xpaset -p ds9 cmap b  
unix% xpaset -p ds9 contour yes 
unix% xpaset -p ds9 contour limits 1 100 
unix% xpaset -p ds9 contour smooth 5 
unix% xpaset -p ds9 contour nlevels 6 
unix% xpaset -p ds9 contour save xpa.con

This command line produces Figure 3. 

Figure 3: XPA: x-ray data with contours
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The options direct ds9 to: 

1.  xpaset -p bin about 3800 3800  : center the image display at (x,y)=(3800,3800) 
2.  xpaset -p bin factor 2  : bin the data by a factor of 2 
3.  xpaset -p scale log  : set the display to log scale 
4.  xpaset -p cmap b  : use the "b" colormap 
5.  xpaset -p contour yes  : display contours 
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6.  xpaset -p contour limits 1 100  : set the minimum and maximum contour limits 
7.  xpaset -p contour smooth 5  : set contour smoothness to "5" 
8.  xpaset -p contour nlevels 6  : create six contour levels 
9.  xpaset -p contour save xpa.com  : save the contours to the file "xpa.con" 

As long as the ds9 GUI remains open, we can continue to modify the display. Here we build on the
previous example by retrieving a DSS image and copying the contours to the new frame: 

unix% xpaset -p ds9 contour copy 
unix% xpaset -p ds9 dsssao A2142 
unix% xpaset -p ds9 cmap grey
unix% xpaset -p ds9 contour paste 
unix% xpaset -p ds9 frame first
unix% xpaset -p ds9 match frames wcs

The resulting image is shown in Figure 2. 

Figure 4: XPA: x-ray and optical data with contours
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The options which have been added from the previous command line are: 

1.  xpaset -p contour copy  : copy the x-ray contours 
2.  xpaset -p dsssao A2142  : retrieve a DSS image of A2142 from the DSS-SAO server (there

are also a "dsseso" and "dssstsci" options) 
3.  xpaset -p cmap grey  : use the "grey" colormap in the DSS frame 
4.  xpaset -p contour paste  : paste the x-ray contours onto the optical data 
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5.  xpaset -p frame first  : select the first ds9 frame 
6.  xpaset -p match frames wcs  : match the WCS of the DSS frame to the current (x-ray)

frame 

At this point, we can end the ds9 session, issue further XPA commands, or modify the display
interactively via the ds9 GUI. 

SAMP: Simple Application Messaging Protocol
A third, more advanced method of scripting ds9 is via SAMP, a messaging protocol that enables
astronomy software tools to interoperate and communicate. SAMP is also used by such applications as 
TOPCAT, an interactive graphical viewer and editor for tabular data and Aladin, an interactive software
sky atlas. 

Information on the ds9 SAMP implementation is available in the ds9 Reference Manual. 

History

21Â SepÂ 2009 Original version 

Return to the DS9 Users Manual
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